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2 INSTALLATION AND STARTUP Desktop Icon Backup Manager

1 Introduction

Desktop Icon Backup Manager is a professional tool designed to save and restore Windows
desktop icon positions. The program offers advanced features for managing multiple layouts,
adaptive scaling for different resolutions, and complete automation through configurable settings.

1.1 Key Features

e Quick Backup: Save icon positions with optional descriptive tags

Backup Management: Dedicated interface to select, restore, or delete specific backups

Adaptive Scaling: Option to automatically scale icon positions across different resolutions

Automatic Cleanup: Configurable limit on the number of backups to retain

Random Scramble: Randomize icon positions with automatic preventive backup

System Tray Integration: Quick access to main functions from the system tray

Automation: Automatic save on exit and automatic restore on startup

1.2 System Requirements
e Operating System: Windows 7 or higher
e Python 3.8+ (if running from source)

e Libraries: PyQt6, pywin32

e Disk Space: 50 MB for the application + space for backups

\

2 Installation and Startup

2.1 Installation

Method 1: Standalone Executable (Recommended)
1. Download the DesktopIconBackupManager .exe file
2. Place the executable in a dedicated folder

3. Run the program with a double-click
Method 2: From Python Source
1. Install Python 3.8 or higher

2. Install dependencies:

pip install PyQt6 pywin32

3. Run the script:

python DesktopIconBackupManager.py
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2.2 First Run

On first run, the program:
e Automatically creates the icon_backups folder for backup files
e Generates the settings.ini configuration file
e Verifies the presence of desktop icons

e Places itself in the system tray

Make sure desktop icons are visible. If icons are hidden, the program will not be able to
access their positions.

3 Main Interface

3.1 Interface Overview

The main interface is divided into four main areas:

1. Menu Bar: Contains File, Settings, and Help

2. Tag and Actions Area: Field for descriptive tags and main action buttons

w

. Activity Log: Displays operation status in real-time

4. Status Bar: Shows current resolution and status messages

3.2 Main Buttons
3.2.1 B SAVE QUICK BACKUP

Color: Green

Immediately saves current desktop icon positions to a new backup file. You can add a
descriptive tag in the field above the button.

Operation:

e Scans all icons present on the desktop
e Records X and Y coordinates for each icon
e Saves metadata (resolution, icon count, timestamp)

e Applies automatic cleanup if configured

3.2.2 © RESTORE LATEST
Color: Red

Restores icon positions from the last saved backup. Before restoring, a confirmation window
is shown with backup details.
Information Displayed:

e Backup file name

e Saved resolution
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e Number of icons
e Tag/description

e Backup date and time

3.2.3 = BACKUP MANAGER

Color: Blue
Opens the backup management window that allows you to:

e View all available backups

Select a specific backup to restore

Delete single or multiple backups

View extended details of each backup

e View a visual layout preview of each backup

4 File Menu

4.1 Scramble Desktop Icons (Random)

This function completely randomizes the positions of all desktop icons.

Before scrambling, an automatic backup is always created with the tag ” Auto-Backup
before Scramble (Random)”. This ensures the ability to restore the previous layout.

Procedure:

1. Select File > Scramble Desktop Icons

2. Confirm the operation in the dialog window
3. The program automatically creates a backup

4. Icons are repositioned randomly

4.2 Remove All Backups

Permanently deletes all saved backup files.

This action cannot be undone. All backups will be permanently deleted from the system.

4.3 Exit

Closes the application. If configured, it can:
e Create an automatic backup before exiting
e Minimize to system tray instead of closing

e Save window geometry
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5 Settings Menu

5.1 Start Minimized to Tray

When enabled, the application starts minimized to the system tray instead of showing the main
window.

Use Case: Useful for users who want to have the program always available in the background
without occupying space in the taskbar.

5.2 Auto-Save on Exit

Automatically creates a backup of current positions when closing the program.

Recommended

This option is strongly recommended to avoid data loss in case of unsaved changes.

Technical Details:
e The backup is created with the tag ” Auto-Save on Exit”
e Respects the configured automatic cleanup limit

e Does not require user confirmation

5.3 Auto-Restore on Startup

Automatically restores the last saved backup when starting the program.
Behavior:

e Restore occurs 1 second after startup
e Uses configured scaling settings

e Shows operation log in the main window

When combined with ” Auto-Save on Exit”, this option creates an automatic save/restore
cycle of icon positions.

5.4 Enable Adaptive Scaling on Restore

Enables adaptive scaling of icon positions when restoring a backup created with a different
resolution.

5.4.1 How Scaling Works

The system calculates scaling factors based on resolution:

current width

scale, =
v saved width

scalo. — current height
Y saved height

Each coordinate is then transformed:
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Tnew = Tsaved X Scaley

Ynew = Ysaved X SCaley

Practical Example:

e Backup saved at 1920x 1080

e Restore on 2560x 1440 monitor

e Scaling factors: scale, = 1.333, scale, = 1.333

e Icon saved at (100, 100) — restored at (133, 133)

5.5 Minimize to Tray on Close

When enabled, pressing the ”X” button minimizes the program to the system tray instead of
closing it completely.
To close completely:

e Use File > Exit
e Right-click on the tray icon and select ” Exit”

e Press Ctrl+Q

5.6 Automatic Backup Cleanup Limit

Configures the maximum number of backups to maintain. When the limit is exceeded, the oldest
backups are automatically deleted.
Available Options:

e Disabled (Keep All): No limit (value: 0)

e Keep Last 5: Keeps only the last 5 backups

e Keep Last 10: Keeps only the last 10 backups
e Keep Last 25: Keeps only the last 25 backups

e Keep Last 50: Keeps only the last 50 backups

Recommended Strategy

For daily use, Keep Last 10 offers a good balance between security and disk space usage.
For power users who frequently change configuration, Keep Last 25 or more is recom-
mended.

6 Advanced Backup Management

6.1 Backup Manager Window

The Backup Manager window offers a complete view of all saved backups.
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6.1.1 Information Columns

1. TAG/DESCRIPTION: Description or tag assigned to the backup
2. RESOLUTION: Monitor resolution at the time of saving
3. ICONS: Number of saved icons

4. TIMESTAMP: Backup date and time in readable format

6.1.2 Available Operations

Restore:
e Double-click on a backup
e Selection + click on ”Restore Selected Layout”
e Right-click ; ”Restore Selected”
Delete:
e Right-click on a backup ; ”Delete Selected”

e Confirmation required before deletion

6.2 Backup File Format

Backups are saved as JSON files in the icon_backups folder.
Naming Convention:

[Resolution] _[Date] _[Time].json

Example: 1920x1080_20241211_143000. json

JSON File Structure:

{
"timestamp": "2024-12-11T14:30:00.123456",
"icon_count": 15,
"description": "Backup Before Meeting",
"display_metadata": {
"monitor_count": 1,
"primary_resolution": "1920x1080",
"screens": [...]
1,
"icons": {
"Computer": [100, 200],
"Documents": [100, 350],
}
}



9 TROUBLESHOOTING Desktop Icon Backup Manager

7 System Tray Integration

7.1 System Tray Context Menu
Right-click on the system tray icon to access:

e Quick Save: Saves a quick backup with default tag ”Quick Save (Tray)”

Restore Latest: Restores the last saved backup

Show Window: Shows the main window

Exit: Completely closes the application

7.2 Notifications

The program shows notifications from the system tray for:

e Operation completion when the window is hidden

Critical errors

Minimized startup

Minimization from window closure

8 Keyboard Shortcuts

Shortcut | Action
Ctrl+S Quick save
Ctrl+Q Exit application

Table 1: Available keyboard shortcuts

9 Troubleshooting

9.1 Common Issues

9.1.1 Error: ”Unable to find desktop ListView control”

Cause: Desktop icons are hidden or the ListView control is not accessible.
Solution:

1. Right-click on the desktop
2. Select View > Show desktop icons

3. Restart the program

9.1.2 Icons Restored to Wrong Positions

Cause: Resolution change or different monitor configuration.
Solutions:

1. Enable ”"Enable Adaptive Scaling on Restore” in settings
2. Create separate backups for each monitor configuration

3. Verify that current resolution matches the backup
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9.1.3 Backup Not Found

Cause: Corrupted or deleted backup file, missing icon_backups folder.
Solution:

1. Verify existence of icon_backups folder
2. Check read/write permissions

3. Verify JSON file integrity

9.2 Logging and Diagnostics

The ” Activity Log” area records all operations and errors. For advanced diagnostics:
1. Execute the problematic operation
2. Copy the log content
3. Check specific error messages

4. Verify settings.ini file for incorrect configurations

10 Best Practices

10.1 Optimal Backup Strategy
e Enable ” Auto-Save on Exit”

e Set automatic cleanup limit to 10-25 backups

e Create manual backups before important changes

e Use descriptive tags for important backups

10.2 Multi-Monitor Management
For multi-monitor configurations:
1. Create separate backups for each configuration
2. Use descriptive tags: 72 Monitors”, ”Single Monitor”, etc.
3. Do not enable auto-restore if frequently changing configuration

4. Always verify monitor configuration before restoring

10.3 Regular Maintenance

Periodically review saved backups

Manually delete obsolete backups if necessary

Check icon_backups folder for space usage

Export important backups to safe locations

10



12 TECHNICAL INFORMATION Desktop Icon Backup Manager

11 Frequently Asked Questions (FAQ)

11.1 Does the program work with Windows 117

Yes, the program is fully compatible with Windows 11 and all previous versions starting from
Windows 7.

11.2 Can I use the program with virtual desktops?

The program manages icons on the main desktop. Icons on Windows 10/11 virtual desktops are
managed by the same system, so the backup includes all visible icons.

11.3 Are backups portable between different computers?

Yes, JSON files can be copied between computers. However, positions may not be accurate if
resolutions differ. Use adaptive scaling for best results.

11.4 How much space do backups occupy?

Each backup typically occupies 2-10 KB depending on the number of icons. With 50 backups,
total usage is generally less than 500 KB.

11.5 Can I manually edit backup files?

Yes, they are standard JSON files. You can edit them with a text editor, but be careful with
JSON syntax to avoid file corruption.

12 Technical Information

12.1 Software Architecture

The program uses:
e PyQt6: Modern GUI framework
e win32api: Low-level access to Windows functions
e Threading: Asynchronous operations to avoid Ul blocking

e QSettings: Configuration persistence in INI format

12.2 Remote Memory Access

To read icon positions, the program:
1. Locates the Explorer process managing the desktop
2. Allocates memory in the remote process
3. Uses Windows messages to query the ListView control
4. Reads coordinates and icon names

5. Frees allocated memory

11



14 SUPPORT AND CONTACTS

Desktop Icon Backup Manager

12.3 Security and Privacy

e No data is sent online
e All backups are local
e No telemetry collection

e Access only to desktop information

13 License and Credits

13.1 Developer

mapi68

13.2 Libraries Used
e PyQt6 - The Qt Company (GPL/Commercial License)

e pywin32 - Python for Windows Extensions (PSF License)

14 Support and Contacts
To report bugs, request features, or get support:

e Use the ”Issues” section of the repository
e Always include the complete error log

e Specify program version and Windows version

12
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15 Screenshots

Backup

File Settings Help

Save Tag: |Backup standard PC

= SAVE QUICK BACKUP & RESTORE LATEST o BACKUP MANAGER

Activity Log:

 Saved 22 icons to backup file "1928x1838_28251285_834336.7s50n" =
(Description: Quick Backup)

Cleanup skipped: Current count (5} is within the limit (18).

Forcing desktop refresh...

Desktop refresh signal sent successfully.

starting new timestamped backup...
(Tag: Backup standard PC)

monitor Resolution: 1928x1888

Found 2@ icons. Starting scan...

« Saved 82 lcons to backup file "192@x183@_28251285_895837.7json”

[89:58:37] (pescription: Backup standard PC)

[@9:58:37] Cleanup skipped: Current count (&) is within the limit (18).

37] Forcing desktop refresh...

:37] Desktop refresh signal sent successfully.

Clear Log

Current Resolution: 1920:10280

Figure 1: Main interface showing the activity log and three main action buttons

or Delete Backup

Select a backup to restore or right-click to delete.

TAG/DESCRIPTION | RESOLUTION | ICONS | TIMESTAMP Layout Preview:
[Auto-Save on Exit] 1928x1088 85 | 2@25/12/24 o
[Auto-Save on Exit] 1328x1888 79 | 2e25/12/16 at 2@:11:83 0000 L. e
[Quick Backupl 1928x1888 79 | 2825/12/16 at 28:18:51 0 | sesas
[Auto-Save on Exit] 1328x1888 83 | 2ea2s5/12/11 at @5:35:51 00| sssss
[Quick Backup] 1928x1888 83 | 2025/12/11 at es:35:38 | sesss
[Auto-Save on Exit] 1928x18ge 79 | 2e25/12/@8 at 21:34:28 2| temes
[Auto-Save on Exit] 1928x18ge 79 | 2e25/12/87 at 2@:35:58 | tf%=®
1928x18288
[Auto- on Exit] 1928x1888 79 &
[Auto-save on Exit] 1328x1888 79 | 2825/12/87 at @6:13:48
[Auto-Save on Exit] 1328x1888 73 | 2825/12/87 at @3:85:38
[Quick Backup] 1328x1888 79 | 2ea25/12/@7 at @3:85:27
[Auto-save on Exit] 1928x1888 79 | 2825/12/86 at 19:16:42 File: 1920x1080_20251207_081753.json
[Auto-Save on Exit] 1928x1888 79 | 2825/12/86 at 18:51:24 leons: 79
[Auto-Save on Exit] 1928x18ge 79 | 2ea5/12/86 at 18 7 Resolution: 1920x1080
[Au‘!_:u—save on Exit] 1928x1828 79 | 2825/12/86 at 18 7 Description: Auto-Save on Exit
[Quick Backup] 1928x1888 79 | 2825/12/86 at 18:48:48 Timestamp:
[Auto-5ave on Exit] 1928x1888 79 | 2825/12/86 at 18:49:32
[Auto-save on Exit] 1928x1080 81 | 2@25/12/85 :154: 2025-12-07T08:17:53.555764
[Quick Backup] 1328x1888 81 | 2eas5/12/@5 HEH
[Auto-save on Exit] 1928x1282 83 2825/12/85 152
[Backup standard pPC] 19281888 822 | 2e25/12/85 H-:H
[Quick Backup] 1928x18ge 822 | 2eas5/12/es H

Restore Selected Layout Close

Figure 2: Backup Manager window with list of saved backups and layout preview

13
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ﬂ' Confirm Restore

Restore icon positions from the LATEST backup file:

File: 1920 1080_20251205_095037.json
Resolution: 1920x 1080

lcons: 80

Tag: Backup standard PC

Timestamp: 2025/12/05 at 09:50:37

Are you sure you want to proceed?

Yes Mo

Figure 3: Confirmation dialog before restoring a backup

(-] Desktop lcon Backup Manager di mapi68

File |mpostazioni Aiuto

Opzionale: inserisci un tag o de

= SALVATAGGIO RAPIDO A RIPRISTINA ULTIMO O GESTORE BACKUP

Avvio di un nuovo backup con timestamp...
(Tag: Backup rapido)
Risoluzicne moniteor: l92exlese
Trovate 82 icone. Avvio scansione...
 Salvate 22 icone nel file di backup "1928x1888_ 28251226 894881.7json”
(Descrizione: Backup rapido)
Pulizia necessaria: il numerc attuale (26) supera il limite (25). Eliminazione dei 1 file

Eliminato il backup pil vecchio: 19281888 28251286 191642.7s0n
Pulizia completata. Totale eliminati: 1.
Forzatura aggiornamentc desktop.
segnale di aggiornamento desktop inviato con successo.

Pulisci log

Figure 4: Desktop Icon Backup Manager featuring dark mode and Italian support

End of User Manual
Desktop Icon Backup Manager
December 27, 2025
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